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ВВЕДЕНИЕ 

Многие задачи, с которыми приходится в настоящее время сталкиваться исследователям 
и инженерам, не поддаются аналитическому решению, либо требуют огромных ресурсов на 
экспериментальную реализацию. Зачастую, единственной возможностью быстрого анализа 
инженерной проблемы является компьютерное математическое моделирование. Прогресс в 
разработке численных методов позволил существенно расширить круг задач, доступных 
анализу. Полученные на основе численных методов результаты используются практически во 
всех областях науки и техники. 

В анализе конструкций находит свое наиболее важное применение метод конечных 
элементов. Причем в конструкционном анализе под конструкциями понимаются мосты, здания, 
корпуса морских судов, узлы самолетов, детали машин, поршни, инструменты – словом, любые 
инженерные конструкции. 

Первичными переменными, которые вычисляются в ходе конструкционного анализа, 
являются смещения узлов и силы реакций в закреплениях. В дальнейшем, исходя из 
вычисленных смещений в узлах сетки, определяются и другие важные параметры – такие как 
напряжения, упругая или пластическая деформация и пр. 

В данном учебном пособии основные положения компьютерного инженерного анализа 
рассмотрены в примерах, решенных с помощью программы Ansys Mechanical, которая 
относится к классу «тяжелых» систем и имеет расширенные вычислительные возможности. 

Задачи с первой по седьмую сгруппированы по возрастанию сложности: в первом 
разделе рассказывается об азах интерфейса пакета, в разделах со второго по четвёртый 
раскрываются возможности линейных конечных элементов, пятый и шестой разделы 
посвящены работе с плоскими конечными элементами, в седьмом разделе и далее идёт работа с 
объёмными конечными элементами. 

После восьмого раздела идут сложные задания, посвящённые прочностному 
моделированию двигателей и энергетических установок: моделирование лопатки, крыла 
планера, сборок, тепловые задачи. 

Выполнив данные задачи, студент поучает начальные практические навыки для 
выполнения конструкционного анализа методом конечных элементов в курсовом и дипломном 
проектировании. 
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1 ПОДГОТОВКА К РАБОТЕ И ЗАПУСК ПАКЕТА 
 

1.1 Создание папки на диске 
1) Откройте проводник либо через меню «Пуск – Программы – Проводник – Все 

папки», либо через значок «Мой компьютер» на рабочем столе, либо другим способом. 

Выберите указанный преподавателем диск и папку (по умолчанию D:\Users\). Щёлкните правой 

клавишей мыши – Создать – Папка. 

2) Введите как имя папки номер группы. Если такая папка уже есть, войдите в неё.  

3) Создайте подпапку (Ф.И.О. студента латинскими символами). Закройте меню. 

1.2 Запуск Ansys 
1) Пуск → Программы → Ansys хх.х → Mechanical APDL Product Launcher . 

Выпадающее меню представлено на рис. 1.1. В графе Working Directory укажите  путь к 

созданной ранее рабочей папке. В графе Job Name введите имя задачи латинскими символами и 

цифрами (можно оставить по умолчанию). Нажмите Run. 

 
Рис. 1.1.   Меню запуска Ansys Mechanical 

 
2) После входа в интерактивный режим диалог пользователя с программой 

осуществляется через многооконный «Графический интерфейс пользователя (GUI)» (рис. 1.2). 

Кратко опишем некоторые из них. 

Верхнее горизонтальное окно 1 представляет собой Меню утилит (Utility Menu, далее 

UM), содержит набор часто используемых процедур по работе с моделью, такие как сохранение 

и запуск моделей, отображение различных элементов модели, работа с координатными 

плоскостями и т.д., по мере знакомства с программой вы ознакомитесь с командами, 

содержащимися в UM. 
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Рис 1.2.   Графический интерфейс программы 

Окно 2 представляет собой Главное меню (Ansys Main Menu, далее ММ). Оно содержит 

основные функции и этапы выполнения программы, которые группируются в располагаемые 

сбоку всплывающие (динамические) меню, вид которых зависит от продвижения по программе.  

Окно 3 является Графическим окном. Оно представляет собой область для вывода такой 

графической информации, как конечно-элементная модель или графики результатов анализа. 

Окно 4 представляет собой Окно ввода (Ansys input) – область для набора команд и 

вывод сообщений в Output Window. Имеется возможность обратится к списку введенных раннее 

команд. Команды дублируют действия, проводимые в интерактивном режиме. 

Окно 5 позволяет управлять положением геометрии в пространстве, приближать и 

удалять модель, вращать и т.д. 
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2  РАСЧЕТ НА ПРОЧНОСТЬ КОНСОЛЬНОЙ БАЛКИ С ШАРНИРНЫМ ПОДКОСОМ 

 
Рис. 2.1.  Расчетная схема консольной балки 

 
2.1 Создание узлов конечных элементов 

 
1) Конечные элементы создаются по узлам, в зависимости от типа элемента, для его 

создания необходимо задать от 1-го до 20-и узлов. В данной задаче используется балочный 

конечный элемент (тип Beam). 

2) Создайте узлы, определяющие балку: Main Menu (MM) → PreProcessor (PrPr) → 

Modeling → Create → Nodes → In Active CS. В появившемся окне вводите координаты узлов:  

 x y z 

1 0 0 0 

2 0.5 0 0 

3 1 0 0 

4 0 -0.4 0 

В графе NODE вводится номер узла, причем, если оставить графу пустой, номер 

присвоится автоматически. 

 
Рис. 2.2.  Ввод координат узлов 
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2.2 Задание типа конечного элемента и свойств материала 

1) Тип элемента. Заходите  MM → PrPr → Element Type → Add/Edit/Delete. Выберите  

тип элемента Beam 188 → OK. Необходимо определить тип поперечного сечения балки, в 

данной задаче рассмотрим прямоугольное сечение. Заходите PrPr → Sections → Beam → 

Common Sections. Тип сечения по умолчанию прямоугольник, ширина B=0.05 м, высота 

H=0.08 м. 

 
Рис. 2.3.  Форма поперечного сечения элемента 

 
2) Свойства материала.  PrPr → Material Props → Material Models. Для расчета 

достаточно задать плотность материала, модуль упругости и коэффициент Пуассона. В окне 

Material Models Available выберите Structural – Density и задайте плотность DENS = 7800 

(кг/м3). Затем выберите Linear – Elastic – Isotropic. Задайте: модуль упругости ЕХ=2·1011 (Па); 

коэффициент Пуассона PRXY=0.3.  

2.3 Генерация конечных элементов по созданным узлам  
1) Задайте атрибуты создаваемых конечных элементов: PrPr → Meshing → Mesh 

Attributes → Default Attribs 

 
Рис. 2.4.  Атрибуты конечных элементов 
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В графе Type выставляется тип конечного элемента, который будет создаваться по 

узлам, в графе MAT номер материала, в графе SECNUM номер поперечного сечения балочного 

элемента. Оставляйте в данной задаче все по-умолчанию. 

2) Создайте по созданным в пункте 2.1.2 узлам конечные элементы: PrPr → Create → 

Elements → Auto Numbered → Thru Nodes. Выбирайте по два узла, начиная с  1-2. Меню 

выбора узлов представлено на рис. 2.5. Для переключения между режимом выбора и отмены 

выбора нажимайте правую кнопку мыши (ПКМ), в окне ввода можно вводить номера узлов, 

которые необходимо выбрать, для сброса выбора нажмите кнопку Reset. 

 
Рис. 2.5.  Меню выбора узлов 

 
Чтобы отобразить конечные элементы балочного типа необходимо сделать следующее: 

UM → PlotCtrls → Style → Size and Shape → Display of Element → On 

В результате должна получиться следующая конечно-элементная модель (рис. 2.6). 

Возможно потребуется выбрать UM → Plots → Elements, чтобы отобразить элементы.  

 
Рис. 2.6.  Конечно-элементная модель балки 

 
2.4 Ориентация модели и управление видом 

 
1) Для установки ориентации модели, вращения, приближения и удаления заходите UM–

Pan zoom rotate (значок рядом со значком сохранения модели). В выпадающем меню можно 

выставлять вид на модель (Top, Front и т.д.), увеличивать отдельные участки при помощи 
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выделения рамкой (Zoom, Box Zoom), включив Dynamic Mode вращать модель, зажав правую 

кнопку мыши (ПКМ), вписать модель в экран нажав кнопу FIT. 

 

2.5 Приложение граничных условий, запуск на расчет 
 

1) Закрепление модели. PrPr → Loads → Define Loads → Apply → Structural → 

Displacement → On Nodes. Выбирайте узел 4 (шарнирное закрепление) – Apply. В 

выпадающем меню выберите UX, UY (запрет перемещения вдоль выбранных осей, разрешение 

вращения, см. рис. 2.7). 

 
Рис. 2.7.  Моделирование шарнирного закрепления 

 
Далее выберите узел 1, All DOF – запрет любых перемещений, жесткая заделка. 

2) Приложение нагрузки. Зайдите PrPr → Loads → Define Loads → Apply → 

Structural → Force/Moment → On Nodes. Выберите узел 3. Направление силы вдоль оси Y в 

противоположном направлении, значение -10000 Н (рис. 2.8) 

 
Рис. 2.8.   Приложение силы к точке 

 
3) Запуск на расчет. Установка типа расчета: MM → Solution → Analysis Type → 

New Analysis → Static. Запустите модель на расчет: Solution → Solve → Current LS → OK. 

Должна появиться табличка Solution is done! 
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2.6 Анализ результатов расчета 
 

1) Зайдите MM → General Postproc → Plot Results  → Contour Plot → Nodal Solu. 

Отобразите эквивалентные напряжения в конструкции: Stress → von Mises stress; 

2) Отобразите суммарные перемещения в модели, наложенные на начальную форму 

конструкции: MM → General Postproc → Plot Results  → Cntour Plot → Nodal 

Solu DOF Solution → Displacement Vector Sum. В графе Undisplaced shape Key 

поставьте Deformed shape with undeformed model;  

3) Сохраните модель, сделайте скриншоты. Затем удалите созданные узлы и конечные 

элементы. Зайдите PrPr → Modeling → Delete → Elements → Pick all → Ok, затем 

PrPr → Modeling → Delete → Nodes – Pick all → Ok. 

 

2.7 Создание геометрической модели средствами Ansys 
 

1) Создайте начальную и конечную точки, определяющие балку: PrPr → Modeling → 

Create → Keypoints in Active CS. В появившемся окне введите координаты точек:  

 x y z 
1 0 0 0 
2 0.5 0 0 
3 1 0 0 
4 0 -0.4 0 

В графе NPT Keypoint number вводится номер точки, причем если оставить графу 

пустой, номер присвоится автоматически. 

2) Постройте по полученным точкам три линии: PrPr → Modeling → Create → 

Lines  Lines → Straight Line.  В выпадающем меню содержатся подсказки, которые 

показывают, сколько всего нужно выделить точек для данной операции, и сколько максимально 

доступно.  

 При выборе точек графа Count  будет меняться от 0 до 2. Кроме того, точки можно 

выбрать не «кликая» по ним, а вписав их номера через запятую в графу List of Items. Выберите  

построенные точки. Отображение номеров линий и точек доступно в UM → PlotCtrls → 

Numbering. Поставьте напротив KP и Line галочки. 
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Рис. 2.9.  Геометрическая модель в Ansys 

 
2.8 Генерация конечных элементов по линиям 
1)  Присвоение атрибутов геометрической модели. Заходите PrPr → Meshing  → Mesh 

Atrributes → Picked Lines. Присваиваем построенным линиям тип элемента, сечения и номер 

материала (данную операцию можно не делать в случае, если для всех частей геометрической 

модели будут использованы одинаковые свойства, а тип элемента, сечения и материала 

единственный). Кроме того, можно задать ориентационную точку (Pick Orientation Point) для 

поворота сечения относительно оси симметрии; 

2)  Для задания количества элементов по линиям зайдите PrPr → Meshing  →  Size 

Cnrtls → ManualSize → Lines. Выбирайте L1, число элементов задается в графе NDIV, введите 

30 → Apply.  Для L2 NDIV=30, для L3=40. Таким образом, при генерации конечных элементов 

их число будет равно введенным параметрам NDIV; 

3) Для генерации конечных элементов по линиям заходите  PrPr → Meshing → Mesh → 

Lines → Pick All. Чтобы отобразить конечные элементы балочного типа (рис. 2.10) необходимо 

сделать следующее: UM → PlotCtrls → Style → Size and Shape → Display of Element → On; 

 
Рис. 2.10.  Конечно-элементная модель 

 



14 

 

Закрепите модель и запустите на расчет, проделайте это самостоятельно, пользуясь 

предыдущим примером. 

 

2.9 Анализ результатов расчета 
 

1) Заходите MM → General Postproc → Plot Results → Contour Plot → Nodal Solu. 

Отобразите эквивалентные напряжения в конструкции: Stress – von Mises stress 

 
Рис. 2.11.  Эквивалентные напряжения в конструкции 

 
2) Отобразите суммарные перемещения в модели, наложенные на начальную форму 

конструкции: MM  → General Postproc → Plot Results  → Contour Plot → Nodal Solu DOF 

Solution → Displacement Vector Sum. В графе Undisplaced shape Key поставьте Deformed 

shape with undeformed model. Сделайте скриншоты. 

 

 
Рис. 2.12. Суммарные перемещения в конструкции 
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3 РАСЧЕТ НА ПРОЧНОСТЬ БАЛКИ С ДВУТАВРОВЫМ СЕЧЕНИЕМ И 
РАСПРЕДЕЛЕННОЙ НАГРУЗКОЙ 

 
Рассмотрим классическую задачу сопротивления материалов о прямом изгибе в одной 

плоскости упругой многопролетной балки с кусочно-постоянными изгибными жесткостями. 

Внешними силовыми факторами, вызывающими такой изгиб, могут являться сосредоточенные 

силы, моменты и распределенные нагрузки с кусочно-линейным изменением интенсивности. 

 

3.1 Построение точек и линий, определяющих балку 
 
1) В качестве примера возьмем балку с двутавровым поперечным сечением (рис. 3.1).   

 
Рис. 3.1.  Геометрия балки 

 
Данная балка отнесена к декартовой системе координат Oxyz так, что ось x направлена 

вдоль оси балки, проходящей через центры тяжести поперечных сечений. Оси y и z направлены 

вдоль главных осей инерции сечения, а начало отчета расположено в левом конце балки. 

Прямой поперечный изгиб здесь осуществляется в плоскости Oxy. Характеристики 

поперченного сечения (рис. 3.2) возьмем из ГОСТ 19425-74, выберем балку с номером профиля 

20С (табл. 3.1): 

 
Рис. 3.2.  Двутавровое сечение 
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Табл. 3.1 – Исходные данные к расчету 

Параметры 
балки 

a, м q, кН/м M, кН∙м 
 

2 40 20 

Параметры 
сечения 

h, мм b, мм S, мм t 

200 100 7 11,4 

2) Создайте начальную и конечную точки, определяющие балку, а также точку, до 

которой прикладывается погонная нагрузка: PrPr → Modeling → Create → Keypoints in Active 

CS. В появившемся окне введите координаты точек: 

 x y z 
1 0 0 0 
2 2 0 0 
3 6 0 0 

 
3) По полученным точкам проведите два отрезка: PrPr → Modeling → Create → 

Lines → Lines → Straight Line. Выбирайте точки 1 и 2 → Apply, затем 2 и 3 → OK . 

 

3.2 Создание конечно-элементной модели 
 

1) Тип элемента. Заходите  PrPr → Element Type → Add/Edit/Delete. Выбирайте  

тип элемента Beam 188 → OK. Необходимо задать тип поперечного сечения. Заходите PrPr → 

Sections → Beam → Common Sections, выбирайте двутавр в качестве типа сечения (рис. 3.3)  

 
Рис. 3.3.  Параметры двутавра 
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2) Свойства материала. PrPr → Material Props → Material Models. Задать: модуль 

упругости ЕХ=2·1011 (Па); плотность DENS = 7800 (кг/м3); коэффициент Пуассона PRXY=0.3; 

3) Для ориентации сечения балки в пространстве задается ориентационная точка. 

Для ориентации двутаврового сечения вдоль оси Y (рис. 3.4) создайте точку 4 (0,1,0).  

 
Рис. 3.4.  Расположение ориентационной точки 

 
4) Задайте атрибуты создаваемых конечных элементов: PrPr → Meshing → Mesh 

Attributes → All Lines. В графе Pick Orientation Keypoint поставьте Yes. Выберете точку 4 в 

качестве ориентационной; 

 
Рис. 3.5.  Атрибуты конечных элементов 

  
5) Задайте количество создаваемых элементов по линиям. PrPr → Meshing  → Size 

Cnrtls → ManualSize → Lines. Выбирайте L1, NDIV=10 → Apply.  Для L2 NDIV=20. 
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6) Сгенерируйте сетку конечных элементов: PrPr → Meshing → Mesh–Lines → Pick 

All. Чтобы отобразить конечные элементы балочного типа необходимо сделать следующее: UM 

→ PlotCtrls → Style → Size and Shape → Display of Element → On. 

 
Рис. 3.6.  Конечно-элементная модель балки 

 
3.3 Приложение граничных условий и нагрузки 

 
1) Смоделируйте шарнирно-колесную опору (UY=UZ=0):  PrPr → Loads → Define 

Loads → Apply → Structural → Displacement → On Keypoints. Выбирайте точку 

1 – Apply. В выпадающем меню выбрать UY,  затем выбрать  UZ. Смоделируйте 

жесткую заделку:  PrPr → Loads → Define Loads → Apply → Structural → 

Displacement → On Keypoints. Выбирайте точку 3 → All DOF → OK; 

2) Смоделируйте погонную нагрузку. Положительным направлением 

погонной нагрузки считается направление против оси OY. Выберете элементы, 

принадлежащие линии 1: UM → Select → Entities → Lines By Num/Pick → Line 

1. Затем вместо Lines выбирайте Elements, Attached to Lines, Reselect 

(используется только выбранная линия) → OK (рис. 3.7). Теперь, нажав Plot 

Elements, вы увидите только выбранные элементы; 

Для приложения нагрузки заходите: 

PrPr → Loads → Define Loads → Apply → Structural → Pressure → 

On Beam → Pick All, ValI=40000 → OK. Выберете теперь скрытые линии и элементы: UМ → 

Select → Everything; 

3) Приложите крутящий момент в точке. Положительным считаемся момент, 

направленный против часовой стрелки. Заходите PrPr → Loads → Define Loads → Apply → 

Structural → Force/Moment →On Keypoints ,  выбрать точку 2, задать MZ=-20000 

Рис. 3.7 – Выбор 
элементов 
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3.4 Запуск на расчет и анализ результатов расчета 
 

1) Запуск на расчет. Установите тип расчета: MМ  → Solution → Analysis Type → New 

Analysis – Static. Запускайте модель на расчет Solution → Solve → Current LS → OK. 

2) Выведете на экран деформацию модели относительно оси OY (рис. 3.7), наложенную 

на недеформированную модель: MM → General Postproc → Plot Results  → Contour Plot → 

Nodal Solu → DOF Solution → Y-Component of displacement, в графе Undisplaced shape key 

Deformed shape with undeformed model. 

 
Рис. 3.8.  Деформация модели относительно оси OY 

 
3) Постройте эпюру перерезывающих сил Qy. Перерезывающая сила в Ansys имеет 

противоположный знак по сравнению с принятым для эпюр перерезывающих сил. Пользуясь 

Help для элемента Beam 188 находим необходимые команды для задания эпюр. Для построения 

эпюры перерезывающей силы вводим в командную строку следующий текст:         

ETABLE,QYI,SMISC,5 

ETABLE,QYJ,SMISC,18 

PLLS,QYI,QYJ 

Для построения эпюры изгибающего момента  вводим в командную строку следующее:         

ETABLE,MZI,SMISC,2 

ETABLE,MZJ,SMISC,15 

PLLS,MZI,MZJ 

Сохраните скриншоты. Чтобы сохранять скриншоты с белым фоном выберите UM → 

PlotCtrls → Write Metafile → Invert White/Black.         
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4 РАСЧЕТ СВЯЗАННЫХ СТЕРЖНЕЙ, НАГРУЖЕННЫХ ТЕМПЕРАТУРНОЙ 
НАГРУЗКОЙ И РАСТЯГИВАЮЩЕЙ СИЛОЙ 

Рассмотрим систему стержней, связанных между собой балкой (рис. 4.1): 

 
Рис. 4.1. Система стержней 

Три стержня одинаковой длины соединены между собой балкой, центральный стержень 

нагружен растягивающим усилием Q=10 кН. Кроме того, стержни нагружены температурным 

градиентом CT 0300 . Два стержня выполнены из меди, центральный стержень из стали. 

4.1 Построение геометрической модели 
1) Создайте начальные и конечные точки, определяющие стержни: MM → PreProcessor 

→ Modeling → Create → Keypoints in Active CS. В появившемся окне вводите координаты 

точек: 

 x y z 
1 0 0 0 
2 0.04 0 0 
3 0.08 0 0 
4 0 0.08 0 
5 0.04 0.08 0 
6 0.08 0.08 0 

2)  Создайте отрезки между точками 1 и 4, 2 и 5, 3 и 6 (рис. 4.2) 

 
Рис. 4.2.  Построение отрезков 
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MM → PreProcessor → Modeling → Create → Lines → Lines → Straight Line. 

Выбирайте точки 1 и 4, → Apply, затем 2 и 5 → Apply, затем 3 и 6  → OK. 

 

4.2 Тип конечного элемента и свойства материала 
 

1) Задайте тип элемента. Заходите  MM → Preprocessor → Element Type → 

Add/Edit/Delete. Выбирайте  тип элемента Beam 188 → OK. Задайте тип поперечного сечения: 

MM → Preprocessor → Sections → Beam → Common Sections, выбирайте прямоугольное 

поперечное сечение, задав B=H= 0.001 м; 

2) Задайте свойства меди и стали. MM →  Preprocessor → Material Props → Material 

Models. Для стали: Е=2·1011 (Па);  плотность 7800 (кг/м3); коэффициент Пуассона 0.3; 

коэффициент температурного расширения (Structural – Thermal Expansion – Secant Coefficient) 

α=11,85·10-6 1/0C. Создайте новый материал №2. Для меди: Е=1,2·1011 (Па);  плотность 8950 

(кг/м3); коэффициент Пуассона 0,3; коэффициент температурного расширения  α=16,8·10-6 1/0C; 

3) Задайте количество создаваемых элементов по линиям. MM → PrPr → Meshing  

→ Size Cnrtls → ManualSize → Lines. Для всех линий задайте 10 элементов; 

4) Сгенерируйте сетку конечных элементов на медных стержнях. Для этого 

заходите: PrPr → Meshing → Mesh Attribute → Picked Lines. Выбирайте линию 1 и 3, в 

появившемся окне в графе Material number поставьте 2 (номер материала меди). Для стального 

стержня выберете линию 2 и поставьте номер материала 1. Создайте конечные элементы по 

линиям. Чтобы отобразить конечные элементы балочного типа необходимо сделать следующее: 

UM → PlotCtrls → Style → Size and Shape → Display of Element → On; 

 
Рис. 4.3. Конечно-элементная модель 
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4.3 Граничные условия и нагрузка 
1) Свяжите перемещения концов балок в направлении оси Y. MM → Prpr → 

Coupling/Ceqn → Couple DOFs. Выбирайте узлы с номерами 2, 13, 24 (узлы на верхних концах 

стержней), NSET задать 1, Lab задать UY; 

2) Закрепите стержни в основании по всем степеням свободы: PrPr → Loads → Define 

Loads → Apply → Structural → Displacement → On Nodes. Выбирайте узлы  1, 12, 23 → All 

DOF → OK; 

3) Приложите температурную нагрузку PrPr → Loads → Define Loads → Apply → 

Structural → Temperature → On Lines, задайте температуру 300 0С по всем линиям; 

4) Приложите сосредоточенную силу в направлении оси Y к концу стального стержня: 

PrPr → Loads → Define Loads → Apply → Structural → Force/Moment, выберете узел 24, 

задайте FY=10000. 

4.4 Запуск на расчет и вывод результатов 
1) Запуск на расчет. Установка типа расчета: ММ → Solution → Analysis Type → New 

Analysis → Static. Запускайте модель на расчет Solution → Solve → Current LS → OK. 

2) Сравните напряжения, возникающие в стальном стержне с напряжениями, 

возникающими в медном стержне. Выполните в командной строке следующий макрос: 

FINISH 
/POST1                                 
STEEL_N  = NODE (0.04,,,)           
COPPER_N = NODE (0.08,0,0)       
STEEL_E = ENEARN (STEEL_N)    
COPPER_E = ENEARN (COPPER_N) 
ETABLE,STRS_ST,LS,1        
ETABLE,STRS_CO,LS,1    
*GET,STRSS_ST,ELEM,STEEL_E,ETAB,STRS_ST   
*GET,STRSS_CO,ELEM,COPPER_E,ETAB,STRS_CO 
Сохраните скриншоты. 
Самостоятельно проведите расчет следующей модели (рис. 4.4): 

 
Рис. 4.4.  Консольно закрепленный брус 

 
Консольно закрепленный, неравномерно нагретый брус квадратного сечения нагружен 

осевой силой F . Определить максимальные растягивающие напряжения в заделке, а также 

осевое перемещение бруса. 
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5 СОЗДАНИЕ ПОВЕРХНОСТЕЙ В ANSYS 
 

5.1 Создание поверхности по точкам 

1) Создать ключевые точки с координатами: 

 x y z 
1 0 0 0 
2 1 0 0.1 
3 1 1 -0.1 
4 0 2 0.3 

2) Создать поверхность (см. рис. 5.1) по построенным точкам ММ → PrPr → Create → 

Areas → Arbitrary → through KPs; 

3) Последовательно в порядке возрастания номеров выбрать курсором созданные точки; 

4) Нажать ОК. 

 
Рис. 5.1. Создание поверхности по точкам 

 
5.2 Уничтожение поверхности 
1) PrPr → Delete →  Areas only;  

2) Выбрать курсором уничтожаемую поверхность; 

3) Нажать ОК. 

5.3 Создание поверхности по линиям 
1) UM →  Plot → Lines; 

2) MM → PrPr → Create → Areas →  Arbitrarys By lines; 

3) Выбрать курсором линии, ограничивающие создаваемую поверхность; 

4) Нажать ОК; 

5) Сохраните скриншот. Уничтожьте  все данные об объекте: UM → Files →  Clear & 

Start New → OK – yes. 
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5.4 Создание поверхности операцией, подобной натягиванию кожи на каркас 
 

1) Создать ключевые точки с координатами (см. рис. 5.2):  
 

№ х у z 
1 -2.0 0.0 0.0 
2 -1.0 0.5 0.0 
3 0.0 0.8 0.0 
4 1.0 0.4 0.0 
5 2.0 0.0 0.0 

 

 
Рис 5.2.  Первое сечение 

 
2) Создать сплайн по точкам: ММ → PrPr → Сreate → Splines → Spline through KPs. 

3) Создать ключевые точки с координатами (см. рис. 5.3): 

 
№    х у z 
6 -2.0 -0.2 2.0 
7 -1.0 0.6 2.0 
8 0.0 0.8 2.0 
9 1.0 0.5 2.0 

10 2.0 -0.1 2.0 
 

 
Рис 5.3.  Второе сечение 
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4) Создать сплайн по точкам. 

5) Создать ключевые точки с координатами (см. рис. 5.4):  

  
№ х у z 
11 -2.0 0.1 3.0 
12 -1.0 0.5 3.0 
13 0.0 0.7 3.0 
14 1.0 0.3 3.0 
15 2.0 0.1 3.0 

 
6) Создать сплайн по точкам. 

 
Рис 5.4. Третье сечение 

 
7) Создать поверхность (см. рис. 5.5) по сплайнам MM → PrPr → Create → Areas →  

Arbitrary → By Skinning. 

8) Последовательно выбрать курсором три созданных сплайна. 

9) Нажать ОК. 

 
Рис 5.5. Поверхность по сечениям 

 

8) Сохраните скриншот. Уничтожьте все данные об объекте. 
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5.5 Создание поверхности вращением линии вокруг оси 
 

1) Создать ключевые точки с координатами:  

 x y z 

1 -5 0 0 
2 10 0 0 
3 -5 2 0 
4 -2 2 0 
5 2 1 0 
6 6 3 0 
7 8 4 0 
8 10 4.5 0 

2) Создать прямые линии между ключевыми точками KP3…KP4 и KP4…KP5. 

3) Создать сплайн по точкам KP5…KP8. 

4) Вывести на экран номера линий: 

UM → PlotCtrls → Numbering → LINE → ON → OK; 

UM → Plot →  LINE . 

5) Выполнить сопряжение линий (см. рис. 5.6): 

1.  PrPr → Create → Line Fillet; 

2. Выбрать курсором линии L2 и L3; 

3.  Нажать ОК. 

4. Ввести величину радиуса сопряжения RAD = 5. 

5. Нажать ОК. 

6. UM → Plot → Replot. 

 
Рис. 5.6. Построение скруглений 
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6) Создать поверхность вращением линий (см. рис. 5.7): 

1. PrPr → Modeling → Operate → Extrude → Lines → About Axis. 

2. Нажать Pick All. 

3. Выбрать точки KP1 и KP2, определяющие ось вращения. 

4. Нажать ОК. 

5. Задать ARC=360. 

6. Нажать ОК. 

 
Рис 5.7. Поверхность вращения 

 
7) Сохраните скриншот. Уничтожьте все данные об объекте. 
 

5.6 Создание поверхности в виде сегмента круга или кольца 
 

1) PrPr →  Modeling → Create → Areas → Circle →  Partial Annulus. 

2) Ввести координаты центра круга: wp x = 1; wp y = 1. 

3) Ввести внутренний радиус сегмента Rad – 1 = 1(Для создания сегмента круга 

необходимо задавать Rad – 1 = 0). 

4) Ввести угол, под которым расположен относительно оси х радиус, определяющий 

правую границу сегмента:  Theta –1 = 45. 

5) Ввести наружный радиус сегмента: Rad – 2 = 2. 

6) Ввести угол, под которым расположен относительно оси х радиус, определяющий 

левую границу сегмента: Theta –2 = 180. 

7) Нажать ОК. 

8) Сохраните скриншот. Уничтожьте все данные об объекте. 
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5.7 Создание поверхности в виде круга или кольца 
 

1) PrPr →  Modeling → Create → Areas → Circle →  Partial Annulus. 

2) Задать координаты центра круга: wpx = 1; wpy =1. 

3) Задать внутренний радиус круга Rad – 1 = 0. 

4) Задать внешний радиус круга Rad – 2 = 2. 

5) Нажать ОК. 

6) Сохраните скриншот. Уничтожьте все данные об объекте. 
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6 ПОСТРОЕНИЕ  СЕТКИ ОБОЛОЧЕЧНЫХ КОНЕЧНЫХ ЭЛЕМЕНТОВ 
 

6.1 Выбрать тип конечного элемента: 
 

1) PrPr → Element type  → Add/Edit/Delete → Add; 

2) Выбрать в левом окне Shell; 

3) Выбрать в правом окне Elastic 4 node 181; 

4) Нажать ОК; 

5) Нажать Close. 

6.2 Задать свойства материалов и толщину элемента: 
 

1)  PrPr → Material Props → Material Models. В окне Material Models Avalilable 

выберите Structural – Density и задайте плотность стали DENS = 7800 (кг/м3). Затем выберите 

Linear – Elastic – Isotropic. Задайте: модуль упругости стали ЕХ=2·1011 (Па); коэффициент 

Пуассона для стали PRXY=0.3. 

2) PrPr → Sections → Shell → Lay-up → Add/Edit.  Задать: Thickness =  0,002 (м) 

3) Нажать ОК; 

6.3 Построить поверхность в виде прямоугольника с отверстием: 
 

1) PrPr → Modeling → Create → Areas → Rectangle → By Dimensions; 

2) Задать: х1=-2(м); х2=2(м); у1=-1(м); у2=1(м); 

3) Нажать ОК.  

4) Построить круг радиуса R=0.5м с центром, расположенным в точке с  координатами:  

х=0; у=0: 

5) PrPr → Modeling → Create → Areas → Circle → Solid Circle; 

6) Вычесть поверхность А2 (круг) из поверхности А1 (прямоугольник) операцией 

Subtract.  PrPr → Modeling  → Operate → Booleans → Subtract → Areas. Для этого выберите 

сначала прямоугольник, нажмите ОК в окне Subtract Areas, затем выберите круг и снова 

нажмите ОК. 

7) Присвоить построенной поверхности атрибуты: 

8) PrPr → Meshing → MeshAttributes → Picked Areas. Выбрать построенную поверхность; 

9) Нажать ОК; 

10) Задать: номер материала МАТ=1; тип TYPE = 1 (SHELL181); тип системы координат 

ESYS=0;  

11) Нажать ОК. 
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6.4 Задать размер ребра генерируемых конечных элементов 

1) PrPr → Meshing → Size Cntrls → ManualSize → Lines → Picked Lines. Выбрать все 

линии, задать Size (Element edge length) 0.1 м. 

6.5 Сгенерировать произвольную сетку конечных элементов (см. рис. 6.1): 

1) PrPr → Meshing → Mesh → Areas → Free  → Pick All. Сохраните скриншот. 
 

 
Рис. 6.1.  Свободная сетка конечных элементов 

 
6.6 Измельчение сетки оболочных конечных элементов 
PrPr → Meshing → Modify Mesh → Refine At →  Elements. 

1) Поставить метку Circle в меню окна Refine mesh at elements; 

2) Подвести курсор в центр отверстия, нажать левую клавишу и, не отпуская ее, охватить 

окружностью примерно два слоя элементов; 

 

 
Рис 6.2.  Измельчение сетки 

 
3) Поставить метки в окнах Unpick и Single меню Refine mesh at elements; 
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4) Отменить курсором выбор случайно охваченных рамкой элементов (оставить только 

два слоя элементов); 

5) Нажать ОК. 

6) Задать уровень измельчения LEVEL=2. Выбранные элементы уменьшатся (см. рис. 

6.2). 

7) Нажать ОК. Сохраните скриншот. 

6.7 Очищение поверхности от сетки оболочечных конечных элементов 
 

1)  PrPr →Meshing → Clear → Areas. 

2) Выбрать поверхность, на которой уничтожается сетка элементов. 

3) Нажать ОК. 

4) UM → Plot  → Areas. 

 
6.8 Генерация упорядоченной сетки оболочечных конечных элементов 
 
1) Построить ключевую точку KP9 с координатами: x=0; y=0; z=0. 

2) Построить прямые линии между точками КР9 и КР4, КР9 и КР3, КР9 и КР2, КР9 и 

КР1. 

3) Вычесть с помощью операции Divide из поверхности А3 линии L11, L10, L9 и L12: 

4) PrPr → Operate → Divide → Areas by line: 

1. Выбрать поверхность А3; 
2. Нажать ОК; 
3. Выбрать линии L9, L10, L11 и L12;  
4. Нажать ОК. 
 

 
Рис. 6.3. Создание секущих линий 
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5) Выполнить по парное суммирование линий образующих окружность отверстия для 

уменьшения их числа (номера линий и их расположение см. на рис. 6.3): 

1. PrPr → Operate → Add  → Lines; 

2. Выбрать линии L15 и L16; 

3. Нажать ОК; 

4. Нажать Apply; 

5. Выбрать линии L18 и L19; 

6. Нажать ОК; 

7. Нажать Apply; 

8. Выбрать линии L21 и L22; 

9. Нажать ОК; 

10. Выбрать линии L24 и L23; 

11.  Нажать ОК. 

6) Задать количество элементов по линиям PrPr → Size Cntrls → All Lines. 

1.Задать:  NDIV=20. 

2.Нажать ОК.  

7) Сгенерировать упорядоченную сетку конечных элементов PrPr → Mesh → Areas 

Mapped  → 3 or 4 sided → Pick All (см. рис. 6.4). 

 

 
Рис. 6.4.  Упорядоченная сетка конечных элементов 
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7 ОБЪЁМНАЯ СЕТКА КОНЕЧНЫХ ЭЛЕМЕНТОВ 
 

Рассмотрим фрагмент прочностного расчета диска рабочего колеса компрессора 

 
Рис. 7.1.  Объемная модель диска рабочего колеса компрессора 

 
7.1 Создание секторной объемной модели диска 

 
1) Создайте точки, определяющие форму диска: PrPr → Create → KeyPoints → in 

Active CS 
Номера точек X Y Z 
1 -0.025 0.09 0 
2 -0.025 0.115 0 
3 -0.004 0.155 0 
4 -0.004 0.23 0 
5 -0.007 0.230 0 
6 -0.007 0.255 0 
7 -0.004 0.255 0 
8 -0.004 0.29 0 
9 -0.014 0.29 0 
10 -0.014 0.3 0 
11 -0.03 0.3 0 
12 -0.03 0.325 0 

 
2) Так как полотно диска симметрично относительно оси Х, отразите вторую половину 

точек операцией симметрии: PrPr → Modeling → Reflect → all → Y-Z plane; 

3) Создайте две точки с номерами 500 и 501 определяющие ось вращения диска с 

координатами 500 (-0.01,0,0) , 501 (0.01,0,0); 

4) Постройте прямые линии между точками КР1 и КP2, КР2 и КP3, КР3 и КP4, КР4 и 

КP5, КР5 и КP6, КР6 и КP7, КР7 и КP8, КР10 и КP11, KP11 и КР12, КР12 и КР24, КР24 и КР23, 
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КР23 и КР22, КР20 и КР19, КР19 и КР18, КР18 и КР17, КР17 и КР16, КР16 и КР15, КР15 и 

КР14, КР14 и КР13, КР13 и КР1 (см. рис. 7.2); 

5) Постройте дуги окружности между точками КР10 и КР8 с центром в точке КР9 и 

радиусом 0,01, и между точками КР20 и КР22 с центром в точке КР21 и радиусом 0,01; 

6) Сделайте скругление радиусом 0,02 между следующими линиями L1 и L2, L18 и L19, 

L2 L3, L18, L17. PrPr → Modeling → Create → Lines → Line Fillet; 

7) Сделайте скругление радиусом 0,003 между линиями L6 и L4, L13 и L17. На рис.7.2. 

представлен результат всех проделанных операций; 

 
Рис. 7.2. Контур диска 

 
8) Для дальнейшего создания конечно-элементной сетки, 

необходимо создать дополнительные линии. Создайте линии между 

точками К25 и К28, К26 и К27, К29 и К31, К30 и К32, К34 и К19, К33 

и К35, К8 и К20; 

9) Создайте дополнительную точку К39 с координатами (0, 

0.306, 0); 

10) Создайте дугу  по трем точкам КР10, КР22, КР39: PrPr → 

Modeling → Create → Lines → Arcs → Through 3 KPs 

11) Создайте несколько (всего 9) поверхностей по замкнутым 

наборам линий, как показано на рис. 7.3; 

12) Создайте цилиндрическую систему координат: 

1. Совместите рабочую систему координат с глобальной: MM 

→ Workplane → Align WP with Global Cartesian 

2. Поверните рабочую систему координат на 900 относительно 

оси +Y: MM → Workplane → Offset WP by Increments 

 
Рис. 7.3.  Создание 

 поверхностей 
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3. Создайте цилиндрическую систему координат 11 (KCN = 11, KCS = Cylindrical 1), 

совпадающую с рабочей плоскостью: MM →  Workplane → Local Coordinate Systems → 

Create Local CS → At WP origins 

5) Поверните поверхности на угол 30 относительно оси вращения диска: 

1. Перейдите в созданную цилиндрическую систему координат: MM →  Workplane → 

Change Active CS to → Specified Coord Sys → 11 

2. Задайте поворот поверхностей на 30 относительно оси Y: PrPr → Modeling → 

Move/Modify → Areas → Areas. См. рис. 7.4. 

 
Рис. 7.4.  Меню поворота поверхностей 

 
6) Создайте сектор диска операцией продавливания поверхностей: PrPr → Modeling 

→ Operate → Extrude → About Axis. Укажите в качестве двух точек, определяющих ось 

вращения, точки 500 и 501. Задайте угол вращения минус 60. См. рис. 7.5 и 7.6. 

 
Рис. 7.5. Создание сектора вращением 
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Рис. 7.6.  Сектор диска рабочего колеса 

 
7.2 Вырезание паза в ободе диска 
1) Установите рабочую систему координат на ободе диска как показано на рис. 7.7. MM 

→ WorkPlane → AlignWP with → Plane Normal to Line → L93 → Ratio Along Line=0,5. 

Система координат должна установиться в середину линии 93, при этом линия будет нормальна 

к плоскости XY; 

 
Рис. 7.7. Установка рабочей системы координат 

 
2) Сделайте рабочую систему координат активной: MM → WorkPlane → Change Active 

CS to → Working Plane; 

3) Создайте 4 точки, определяющие паз диска: 

1 0.012 0 -0.0085 
2 0.012 0 0.0085 
3 0 0 -0.004132 
4 0 0 0.004132 
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4) Соедините прямыми линиями точки КР64 и КР65, КР65 и КР63, КР63 и КР62, КР62 и 

КР64; 

5) Добавьте скругления радиусом 0,002 м между линиями L96 и L97, и между линиями 

L98 и L97 (рис. 7.8); 

 
Рис. 7.8. Контур паза диска 

 
6) Создайте  поверхность по линиям контура паза: PrPr → Modeling → Create → 

Areas → Arbitrary → By Lines, выбирайте по порядку линии с номерами L95, L96, L99, L97, 

L100, L98 (см. рис. 7.8); 

7) Сделайте глобальную систему координат активной: MM → WorkPlane → 

Change Active CS to → Global Cartesian; 

8) Выдавите в направлении, противоположном  оси Х,  созданную поверхность на 

0,1 м (см. рис. 7.9 и 7.10): PrPr → Modeling → Operate → Extrude → Areas → By XYZ Offset; 

 
Рис. 7.9. Меню выдавливания поверхности 
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Рис. 7.10. Вспомогательный объем для выреза паза 

 
9) Путем вычитания одного объема из другого, создайте паз в секторе диска: PrPr → 

Modeling → Operate → Booleans → Subtract → Volumes (см. рис. 7.11). Выбирайте сначала 

объем диска, затем вспомогательный объем. 

 
Рис. 7.11. Паз в диске 

 
7.3 Подготовка модели к генерации сетки 

 
Для наложения упорядоченной сетки конечных элементов разбейте обод диска на 

несколько объемов, каждый их которых легко разбивается упорядоченной сеткой.  

1) Постройте отрезок из точки 22, перпендикулярный к линии 10: PrPr → Modeling 

→ Create → Line → Lines → Normal to Line. При этом линия 10 разделится на две линии, с 

разделяющей точкой КР64 (рис. 7.12); 
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Рис.7.12.  Вспомогательный отрезок 

2) Разрезать объем обода необходимо рабочей плоскостью (WorkPlane), для этого 

необходимо ее связать с точкам КР64, КР22, КР57: MM → WorkPlane → Align WP with 

Keypoints;  

3) Удалите вспомогательный отрезок: PrPr → Delete → Line and Below → L93; 

4) Разрежьте объем обода диска рабочей плоскостью: PrPr → Operate → Booleans → 

Divide → Volu by WrkPlane; 

5) Проделайте аналогичные действия с другой частью обода диска, вспомогательный 

отрезок строится из точки КР10 (см. рис. 7.12 и 7.13); 

 
Рис. 7.13. Разбиение обода диска  

 
6) Разрежьте  обод горизонтальной рабочей плоскостью. Совместите WorkPlane с 

точками КР82, КР83, К68 (см. рис. 7.12), затем аналогично пп. 4 разрежьте три объема обода, 

указав их в меню булевой операции. Результат на рис. 7.14; 
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Рис. 7.14. Окончательное разбиение обода диска на отдельные объемы 

 
7.4 Генерация сетки конечных элементов 

 
1) Задайте свойства материала диска PrPr → Material Props → Material Models. Для 

стали: Е=2·1011 (Па);  плотность 7800 (кг/м3); коэффициент Пуассона 0,3. 

2) Задайте тип конечного элемента 
1.  PrPr → Element type  → Add/Edit/Delete → Add → Shell → 3D 4node 181 

2. PrPr → Element type  → Add/Edit/Delete → Add → Solid → Brick 8 Node 185 

3)  Задайте количество элементов по линиям так, как указано на рис. 7.15 и 7.16: PrPr → 

Meshing → Size Cntrls → Lines → Picked Lines. 

 
Рис. 7.15. Количество элементов по торцевой поверхности 

 
Рис. 7.16. Количество элементов по боковой поверхности 
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4) Установите тип элемента Shell 181: PrPr → Meshing → Mesh Attributes → All Areas 

5) Разбейте нижнюю торцевую поверхность А105 (рис. 7.15) неупорядоченной сеткой 

конечных элементов: PrPr → Meshing → Mesh → Areas → Free. На основе этой сетки 

будет создаваться объемная сетка КЭ 

6) Установите тип элемента Solid 185 (PrPr → Meshing → Mesh Attributes → All 

Volumes), разбейте нижнюю половину обода диска методом выдавливания (sweep): PrPr → 

Meshing → Mesh → Volume Sweep → Sweep. 

 
Рис. 7.17. Объемная сетка на нижней части обода диска 

 
7) Разбейте оставшиеся объемы обода диска упорядоченной сеткой: PrPr → Meshing → 

Mesh → Volumes → Mapped 4 to 6 sided 

 
Рис. 7.18. Объемная сетка на ободе диска 

 
8) Задайте количество элементов по ребрам полотна диска как показано на рис. 7.19. 
9) Начиная с верхней поверхности (А8), разбейте поверхности полотна конечно-

элементной сеткой. Для А6  укажите тип сетки Free, для остальных тип Маpped. Результат на 
рис. 7.20. 

10)  Разбейте объемы полотна диска конечно-элементной сеткой методом выдавливания: 

PrPr → Meshing → Mesh → Volume Sweep → Sweep. Укажите объемы с номерами от 8 до 1; 

Результат на рис. 7.21.  

11) Удалите сетку с поверхностей: PrPr → Meshing → Clear → Areas → Pick all. 
 
7.5 Граничные условия  и приложение нагрузки 
 
Так как для расчета используется секторная модель, на противоположные грани сектора 

диска нужно наложить условия циклической симметрии, связав перемещения узлов этих граней 
в цилиндрической системе координат в направлении вращения 
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Рис. 7.19. Полотно диска 

 
Рис. 7.20. 2D сетка на 

полотне диска 

 
Рис. 7.21. Конечно-
элементная модель 

сектора диска 
 

1) Выберете  поверхности, принадлежащие противоположным граням сектора: UM 

→ Select → Entities → Areas → By NumPick; Используйте операцию Polygon (см. рис. 7.22) – 

укажите четыре угла полигона, все попавшие внутрь поверхности будут выбраны. 

 
Рис. 7.22. Выбор поверхностей операцией Polygon 

 

A6 
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2) Выберете узлы, принадлежащие этим поверхностям (см. рис. 7.23): UM → Select 

→ Entities → Nodes → Attached to → Areas all → Reselect; 

 
Рис. 7.23. Выбор узлов, принадлежащих противоположным граням сектора 

 
3) Свяжите противоположные узлы условием циклической симметрии: PrPr → 

Coupling/ Ceqn → Offset Nodes. Укажите систему координат 11 (КСN), DY=60 (см. рис. 7.24). 

Выберете все элементы модели: UM → Select → Everything; 

 
Рис. 7.24.  Меню наложения условия циклической симметрии 

 
4) Закрепите сектор диска (пункты с 4 по 8). Выберете поверхности A33 и А36 (см. 

рис. 7.25), затем узлы, принадлежащие этим поверхностям; 
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Рис. 7.25. Поверхности для закрепления модели 

 
5) Закрепление модели удобно проводить в цилиндрической системе координат. 

Перейдите в локальную цилиндрическую систему координат 11: UM → WorkPlane → Change 

Active CS to → Specified Coord Sys → 11; 

6) Переместите выбранные узлы в локальную систему координат: PrPr → Modeling 

→ Move/Modify → Rotate Node CS → to Active CS; 

7) Закрепите модель, запретив осевые (UZ) и радиальные (UY) перемещения: PrPr 

→ Loads → Define Loads → Apply → Structural → Displacement → On Nodes; 

8) Выберете всю модель: MM → Select → Everything; 

9) Приложите центробежную нагрузку 600 рад/с: PrPr → Loads → Define Loads → 

Apply → Structural → Inertia → Angular Velocity → Global → OmegX=600; 

10) Запустите модель на расчет: Solution → Analysis Type → New Analysis → Static. 

Solution → Solve → Curent LS; 

11) Выведете на экран окружные  и радиальные напряжения в диске:  

1. Задайте вывод результатов в цилиндрической системе координат: General 

Postproc → Options for Outp  - в графе RSYS поставьте Local system и выберите 11 систему 

координат (см. рис. 7.26). 
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Рис. 7.26 Вывод результатов расчета в цилиндрической системе координат 

 
2. Выведете окружные напряжения: General Postproc → Plot Results → Contour Plot 

→ Nodal Solu → Stress – X-Component of stress 
3. Выведете окружные напряжения: General Postproc → Plot Results → Contour Plot 

→ Nodal Solu → Stress – Y-Component of stress 
Сохраните скриншоты. 
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8 РАСЧЕТ ПЕРА ЛОПАТКИ  РАБОЧЕГО КОЛЕСА КОМПРЕССОРА 
Трехмерная модель пера лопатки компрессора была построена в программном комплексе 

NX7.5 (Unigraphics). Для экспорта в Ansys, модель пера лопатки была сохранена в  формате 

Parasolid (файл с расширением *.x_t). Возьмите модель у преподавателя. 

8.1 Импорт в Ansys модели лопатки 
1) MM → File → Import → Para, в появившемся окне укажите путь к   файлу lopatka.x_t 

(путь не должен содержать символов кириллицы). На экране появится каркасная модель 

лопатки; 

2) Отобразите объем лопатки: MM → PlotCtrls → Style → Solid Model Facets, в окне 

Style of area and volume plots выберете Normal Faceting. На экране появится 3D-модель 

лопатки (рис. 8.1); 

 

Рис. 8.1. Объемная модель лопатки 

8.2 Задание типов конечных элементов 
1) Задайте оболочечный конечный элемент Shell181, который будет являться 

вспомогательным для построения объемной сетки; 

2) Задайте объемный 8-ми узловой конечный элемент Solid185; 

3) Задайте объемный 20-ти узловой конечный элемент Solid186. 
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8.3 Задание свойств материала 
1) Задайте в качестве материала лопатки титановый сплав ВТ9 со следующими 

свойствами: плотность 4500 кг/м3, модуль упругости 1,4∙1011 Н/м2, коэффициент 

Пуассона 0,3. 

8.4 Создание сетки конечных элементов 
В данном примере будет создаваться два типа сетки – сетка с 8-ми узловыми 

элементами, т.е. упорядоченная структурная сетка, и сетка с 20-ми узловыми кэ, т.е. свободная 

сетка. Сохраните файл базы данных, чтобы использовать его при построении второго типа 

сетки: 

1) Разбейте объема пера лопатки на три объема. Удалите объем и поверхности пера, 

оставив при этом только линии, определяющие облик пера: PrPr → Modeling → 

Delete → Volumes Only → Pick all; PrPr → Modeling → Delete → Areas Only → 

Pick all; 

2) Проведите отрезки между точками на кромках втулочного и периферийного 

сечения как показано на рис. 8.2; 

 
Рис. 8.2 – Входная кромка периферийного сечения 

3) Создайте  поверхность по четырем линиям, две из которых являются образующими 

пера лопатки, две созданными дополнительными отрезками на втулке и периферии, 
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выбирая поверхности по порядку по или против часовой стрелки: PrPr → 

Modeling → Areas → Arbitrary → By Lines. 

4) Создайте поверхность по четырем линиям, две из которых являются дугами на 

периферии и втулке, две созданными дополнительными отрезками на втулке и 

периферии, выбирая поверхности по порядку по или против часовой стрелки; 

5) Создайте две поверхности по двум линиям на втулочном и периферийном сечении 

входной кромки; 

6) По созданным поверхностям создайте объем входной кромки: PrPr → Modeling → 

Volumes → Arbitrary → By Areas (рис. 8.3.); 

 
Рис. 8.3 Объем входной кромки 

7) Аналогично создайте объемы срединной части пера и выходной кромки (рис. 8.4) ; 
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Рис. 8.4. Объемы пера лопатки 

8) Задайте по образующим лопатки 100 ребер конечных элементов; 

9) Задайте по поперечным линиям срединной части пера 3 ребра конечных элементов; 

10) Задайте по спинке и корытцу втулочного и периферийного сечений по 50 ребер 
конечных элементов; 

11) Задайте по кромочным дугам по 5 ребер конечных элементов; 

12) Разбейте периферийную поверхность срединной части пера оболочечной сеткой 

конечных элементов (рис. 8.5): PrPr → Meshing → Mesh → Areas → Mapped → 3 

or 4 Sided. 

 
Рис. 8.5 Сетка на срединной поверхности периферийного сечения 
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13) Задайте размер для оболочечных элементов на кромочных поверхностях 

периферийного сечения размер 0,0001: PrPr → Meshing → MeshTool → Areas → 

Set, в появившемся окне ввести максимальный размер элемента, Apply; 

14) Разбейте поверхности кромок периферийного сечения: В окне MeshTool (рис. 8.6) 

в графе Mesh поставьте Areas, в графе Shape поставьте квадратный тип кэ (Quad), 

сетка Free (рис. 8.7); 

 

Рис.8.6 Окно меню задания свойств сетки 

15) Задайте объемам пера лопатки тип конечного элемента и материал: PrPr → 

Meshing → Mesh Attributes → Picked Volumes, операцией Pick выбрать три 

объема, присвоить материал 1, тип элемента 2 (Solid185); 

16) Создайте объемную сетку конечных элементов (рис. 8.8.) вытягиванием 

поверхностной сетки: PrPr → Meshing → Mesh → Volume Sweep; 
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Рис. 8.7. Сетка на входной кромке периферийного сечения 

 

 
Рис. 8.8. Объемная сетка конечных элементов 

 
17) Удалите поверхностную сетку: PrPr → Meshing → Clear → Areas → Pick All; 

8.5 Приложение нагрузки и граничных условий 
1) Закрепите лопатку по втулочному (большему) сечению; 

2) Приложите центробежную нагрузку, равную 500 рад/с, ось вращения ОХ. 
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8.6 Обработка результатов расчета 
1) Вывести на экран растягивающие напряжения (SZ): General Postproc → Plot 

Results → Contour Plot → Nodal Solu (см. рис. 8.9); 

 
Рис. 8.9 Растягивающие напряжения в лопатке 

 
2) Постройте график изменения напряжений по втулочному сечению: General Postproc 

→ Path Operations → Define Path → By Nodes, выбрать строго по порядку внешние 

узлы на втулочном сечении, начиная от входной кромки со спинки. Для удобства 

выбора отобразите на экране только узлы во втулочном сечении. Для этого сначала 

выберите MM → Select → Entities → Lines/By Num/Pick и укажите линии контура 

втулочного сечения.  Затем выберите MM → Select → Entities → Nodes/Attached 

to/Lines, all → OK для выбора узлов, принадлежащих этим линиям. Отобразите узлы 

MM → Plot → Nodes.  После выбора внешних узлов в появившемся окне введите имя 

пути Put, остальные параметры оставьте без изменений; 

3) Задайте требуемые для вывода величины на графике: General Postproc → Path 

Operations → Map onto Path, в появившемся окне через Apply поочередно выберите 

напряжения SX, SY,SZ; 

4) Выведет на экран графики напряжений: General Postproc → Plot Path Item → On 

Graph (см. рис. 8.10.); 
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Рис. 8.10. Графики изменения напряжений по втулочному сечению 

 
5) Сохраните полученные графики: MM → PlotCtrls → HardCopy → To File. В 

появившемся окне поставьте расширение JPEG, включить Reverse Video для белого 
фона, напишите название графика. 
 

8.7 Создание свободной сетки конечных элементов 
1) Загрузите сохраненный ранее файл с объемом лопатки; 

2) Задайте максимальный размер конечного элемента: 

3) Присвойте атрибуты объему пера лопатки, выбрав тип элемента 3 (Solid186); 

4) Сгенерируйте свободную сетку конечных элементов; 

5) Удалите сетку; 

6) Для улучшения качества сетки, уменьшите максимально допустимый размер кэ-

элемента;  

7) Сгенерируйте сетку конечных элементов. 

8.8 Приложение нагрузки и граничных условий 
1) Закрепите модель, приложите нагрузку и запустите на расчет 

8.9 Обработка результатов расчета лопатки со свободной сеткой 
1) Постройте график изменения напряжений по втулочному сечению 

2) Сохраните полученные графики 

3) Сравните графики, полученные для расчета лопатки с упорядоченной сеткой и 

графики, полученные для лопатки со свободной сеткой 
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9 ОПРЕДЕЛЕНИЕ СОБСТВЕННЫХ ФОРМ И ЧАСТОТ КОЛЕБАНИЙ КРЫЛА 
ПЛАНЕРА 

 

Для определения частот и форм собственных колебаний конструкции применяется 

частотный анализ. Знание параметров собственных колебаний становится важным в условиях 

динамического нагружения и при моделировании вибраций и переходных процессов в 

конструкциях. 

 

9.1 Построение геометрии крыла 
1) Построить точки со следующими координатами: 

 x y z 
1 0 0 0 
2 2 0 0 
3 2,3 0,2 0 
4 1,9 0,45 0 
5 1 0,25 0 

 
2) Соедините прямой линией точки КР1 и КР2, КР5 и КР1. 
3) Построите сплайн по точкам КР2, КР3,КР4,КР5 с заданием координат вектора, 

направленного по касательной к сплайну в начальной точке, и вектора, направленного по 
касательной к сплайну в конечной токчке: PrPr → Modeling → Create → Lines → Splines → 
With Options → Spline thru KPs. Указать подряд точки 2 - 5, в выпадающем меню задать 
параметры согласно рис. 9.1. 

 

 
Рис. 9.1. Генерация сплайна с заданием касательных 

 
4) Сгенерируйте поверхность по трем линиям: PrPr → Modeling → Create → Areas → 
Arbitrary → By Lines, выберете подряд три линии (см. рис. 9.2). 

 
Рис. 9.2. Поверхность торцевой части крыла 
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9.2 Создание конечно-элементной модели 
1) Задайте тип элемента:  

1. PrPr → Element type  → Add/Edit/Delete → Add → Shell → 3D 4node 181 

2. PrPr → Element type  → Add/Edit/Delete → Add → Solid → Brick 8 Node 185 

2) Назначьте свойства материала: PrPr → Material Props → Material Models. Е=1,3·1011 

(Па);  плотность 4500 (кг/м3); коэффициент Пуассона 0,3. 

3) Задать длину величину элемента по линиям: PrPr → Meshing → Size Cntrls → 
Manual Size → Global  →  Size, укажите длину элемента 0,2 (рис. 9.3.) 

 

Рис. 9.3.  Длина элемента вдоль линии 

4) Разбейте поверхность свободной сеткой конечных элементов: PrPr → Meshing → 
Mesh → Areas → Free (рис. 9.4.) 

 
Рис. 9.4. Плоская сетка конечных элементов 

 
5) Выберете тип элемента 2: PrPr → Meshing → Mesh Attributes → Default Attribs 

→ [Element Type Number > Solid 185 > OK]; 
6) Вытяните поверхность вдоль оси Z, при этом задайте опции для создания 

объемных элементов (рис. 9.5.): 
1. PrPr – Modeling → Operate → Elem Ext Opts → [No.  Elem divs > 10; Clear areas 

after ext > Yes > OK] 
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Рис. 9.5. Опции для создания объемной сетки 

 
2. PrPr → Operate → Extrude → Areas → By XYZ Offset → DZ=10. В результате 

должна получиться следующая сетка (рис. 9.6.)  

 
Рис. 9.6.  Конечно-элементная модель крыла планера 

 
9.3 Граничные условия и запуск на расчет 

1) Закрепите крыло по одной из торцевых поверхностей, выбрав узлы, принадлежащие 

ей: 

1. UM → Select → Entities → [Nodes → By Loaction → Z coordinates – 

Min,Max>0>OK] 

2. PrPr → Loads → Define Loads → Apply → Structural → Displacement → On Nodes 

→ Pick All → All DOF 

3. UM → Select → Everything  
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2) Задайте тип расчета: Solution → Analysis Type → New Analysis → [Modal>OK] 

3) Задайте число извлекаемых собственных форм:  Solution – Analysis Type – Analysis 

Options – [No. of modes to extract>5; No. of modes to expand>5]; 

 4) Запустите  модель на расчет: Solution → Solve → Curent LS. 

9.4 Анализ результатов расчета 
 

1) Выведите на экран собственные частоты колебаний лопатки (рис. 9.7.): General 
Postproc – Results Summary  

 
Рис. 9.7. Собственные частоты колебаний крыла 

6) Выведете на экран различные собственные формы колебаний крыла 

1. Выберете форму колебаний для вывода: General Postproc → Read Results → By 

Pick –Set 1 

2. Выведете на экран первую форму колебаний (рис. 9.8.): General Postproc → Plot 

Results → Nodal Solu → DOF Solution → Displacement vector sum. В настройках поставьте 

масштаб 100, вывод деформированной конструкции с исходной формой (рис. 9.9.) 
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Рис.9.8. Первая форма колебаний крыла 

 

 
Рис. 9.9. Настройка вывода результатов 

7) Создайте анимацию колебаний крыла по третьей форме: 

1.Выберете форму колебаний для вывода: General Postproc → Read Results → By Pick 

→Set 3 

2.  Настройте анимацию: MM – PlotCtrls → Animate → Deformed Results → [No. of 

frames to create>25, Item > DOF solution → Translation USUM]. 



59 

 

10 СВЯЗЫВАНИЕ СТЕПЕНЕЙ СВОБОДЫ, МОДЕЛИРОВАНИЕ ОГРАНИЧЕНИЙ 

В задачах 10 и 11 углубленное изучение возможностей пакета производится на примере 
моделирования процесса остывания заготовки в разьёмной форме. Сначала задача 
рассматривается в плоскости, обе части формы выполнены в виде прямоугольников. Затем 
задача ставится в объёме. В конце рассматривается распределение температур в плоскости 
разъёма. 

10.1  Построить два прямоугольника 
1. PrPr Create   Rectangle  By Dimensions; 
2. Задать: х1=0(м); х2=0.4(м); у1=-0.1(м); у2=0.1(м); 
3. Нажать Apply; 
4. Задать: х1=0.45(м); х2=0.85(м); у1=-0.15(м); у2=0.15(м); 
5. Нажать ОК. 

10.2. Выбрать в качестве типа конечного элемента Shell 63. Если элемента нет в списке, 
достаточно в поле с названием ввести его номер и нажать OK. Например, вместо «3D     
4node 181» пишется просто «181». Так же можно выбрать и элемент «63». 

10.3. Задать в Real constants толщину оболочных конечных элементов, равной 0,05 м 
(ТК(I)=0.05). 

10.4. Задать свойства материала: Е = 2·1011Па; =7800 кг/м3; μ=0,3. В окне Material Models 
Available выберите Structural – Density и задайте плотность DENS = 7800 (кг/м3). Затем 
выберите Linear – Elastic – Isotropic. Задайте: модуль упругости ЕХ=2e11 (Па); 
коэффициент Пуассона PRXY=0.3. 

10.5. Построить в пластинах упорядоченную сетку конечных элементов (см. рис. 10.1): 
1. PrPr  Size Cntrls  Picked Lines;   
2. Выбрать линии L2 и L4; 
3. Нажать ОК; 
4. Задать: NDIV=7; 
5. Нажать Apply; 
6. Выбрать линии L1, L3, L5 и L7; 
7. Нажать ОК; 
8. Задать: NDIV=8; 
9. Нажать Apply; 
10. Выбрать линии L6 и L8; 
11. Нажать ОК;  
12. Задать:  NDIV=10; 
13. Нажать ОК; 
14. PrPr  Mesh   -Areas-Mapped  3 or 4 Sided  Pick All. 

10.6. Жестко заделать пластины по линиям L4 и L6 (см. рис. 10.2): 
1. PrPr  Loads   Apply  Displacement  On lines; 
2. Выбрать линии L4 и L6; 
3. Нажать ОК; 
4. Выбрать All DOF;  
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5. Нажать ОК. 
 

10.7. Наложение условия равенства перемещений в узлах, расположенных на линиях  
1. PrPr Coupliny/Ceqn   Couple DOFs. 
2. Поставить метку в окне ВОХ меню Define Coupled DOFs. 
3. Охватить рамкой узлы, расположенные на линиях L2 и L8. 
4. Нажать ОК. 
5. Задать:  NSET=1. 
6. Выбрать в окне Lab перемещение UX. 
7. Нажать Apply. 
8. Охватить рамкой узлы, расположенные на линиях L2 и L8. 
9. Нажать ОК. 

10. Задать:  NSET=2.  
11. Выбрать в окне Lab перемещение UY.  
12. Нажать ОК. (В результате выполненных операций все узлы на линиях L2 и L8 

будут иметь одинаковые смещения в направлениях осей Х  и Y глобальной 
декартовой системы координат, см. рис. 10.3).  

 
Рис. 10.1.  Связываемые участки конструкции 

 

 
Рис. 10.2. Закрепление пластин 
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10.8. Уничтожение наложенных связей 
1. Сохраните скриншот. PrPr  Coupliny/Ceqn   Del Coupled Sets. 
2. Задать в первом верхнем окне: NSET1=1. 
3. Нажать Apply. 
4. Обновить изображение модели на экране: UM  Plot   Replot. 
5. Задать в первом верхнем окне: NSET1=All. 
6. Нажать ОК. 

 
Рис. 10.3. Отображение связанных участков 

10.9. Наложение ограничений на узловые перемещения (см. рис. 10.4) 
1. Наложить на узловые перемещения следующие два ограничения: 

1) Обеспечить, чтобы линейное перемещение в направлении оси z (UZ) в узле 10 было 
на 0.003м больше, чем аналогичное перемещение в узле 92; 

2) Обеспечить, чтобы угловое смещение относительно оси х (ROT Х) в узле 2 было 
всегда направлено противоположно аналогичному угловому смещению в узле 73. 

Запишем данные ограничения в виде следующих двух уравнений: 
UZ10 = UZ92+0,003; 
ROT X2 = -ROT X73. 

Преобразуем уравнения к следующему виду: 
K1·UZ10+K2·UZ92=0.003;                 (1) 
K3·ROT X2+K4·ROT X73=0,           (2) 

где K1= 1; K2= -1; K3= 1; K4= 1. 

2. PrPr  Coupliny/Ceqn   Constraint Eqn. 
3. Задать: номер уравнения NEQN=1; CONST=0.003; номер первого узла NODE1=10; 

вид перемещения в первом узле Lab1=UZ; C1=K1=1; номер второго узла NODE2=92;  
вид перемещения во втором узле Lab2=UZ; С2=К2= -1 (см. рис. 10.4) 

4. Нажать ОК. 
5. Задать:  NEQN=2; CONST=0;  NODE1=2; Lab1=ROTX; C1=K3=1; NODE2=73; 

Lab2=ROTX; С2=К4= -1. 
6. Нажать ОК..  
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7. Вывести на экран файл  с текстом  уравнений:  UM  List   Other  Constraint 
Eqns  Any CE NODE Selected.   

8. Сделать скриншоты. Уничтожить оба уравнения: 
1. PrPr  Coupliny/Ceqn   Del Constr Eqn; 
2. Задать NEQN1=1, NEQN2=2, NINC=1; 
3. Нажать ОК. 

9. Сделать скриншоты. Уничтожить все данные операцией Clear & Start New . 
 

 
Рис. 10.4. Связывание узлов по определенному закону 

 
10.10. Наложение связей на совпадающие узлы в 3D-постановке 

1. Построить призму: 
1. PrPr  Create   Prism  Square 
2. Задать: wpx=0; wpy=0; Radius=0.2 м; Theta=45; Depth=0.8; 
3. Нажать ОК. Объём созданной призмы будет иметь номер V1. 

2. Вывести на экран изометрическое изображение призмы. В ходе дальнейших 
операций созданная призма разрезается рабочей плоскостью под определённым 
углом. Для закрепления навыков полученные половинки копируются, склеиваются 
и вычитаются, пока снова не остаётся 2 половинки. Затем каждая половинка 
разбивается сеткой конечных элементов. 

3. Построить в середине линии L9 ключевую точку: 
1. PrPr Create   Keypoints  On line w/Ratio; 
2. Выбрать линию L9; 
3. Нажать ОК; 
4. Задать Line ratio=0,5; 
5. Нажать ОК. 

4. Поместить  в созданную точку систему координат, связанную с рабочей 
плоскостью: 

1. UM  Work Plane   Offset  WP  to  Keypoints; 
2. Выбрать ключевую точку КР9; 
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3. Нажать ОК . 
5. Повернуть рабочую плоскость относительно оси WY на 200: 

1. UM  Work Plane   Offset WP by Increments; 
2. Задать Degees=20; 
3. Нажать на кнопку + y. 

6. Вычесть из объема рабочую плоскость: 
1. PrPr  Operate  Divide  Volu by Wrkplane; 
2. Нажать Pick All. Призма V1 разделится на 2 неравных объёма: V2 и V3. 

7. Построить ещё две копии объема V2: 
1. PrPr  Copy  Volumes; 
2. Выбрать объем V2; 
3. Нажать ОК; 
4. Задать:  ITIME=3; 
5. Нажать ОК. Копии получат свободные номера V1 и V4. 

8. Сложить объемы V2 и V3: 
1. PrPr  Operate  Add  Volumes; 
2. Выбрать объемы V2 и V3; 
3. Нажать ОК. Появится объём V5, такой же, как исходная призма. 

9. Вычесть из полученного объема V5 объем V1: 
1. PrPr  Operate  Subtract  Volumes; 
2. Выбрать объем V5; 
3. Нажать ОК; 
4. Выбрать объем V1; 
5. Нажать ОК. Останутся объёмы V2 и V4 – половинки призмы. 

10. Выбрать в качестве типа элемента Solid 45. 
11.  Задать свойства материала: Е = 2·1011Па; =7800 кг/м3; μ=0.3. 
12. Построить в объемах V4 и V2 упорядоченную сетку конечных элементов (см. 

рис. 10.5): 
1. PrPr  Meshing  Mesh Attributes  All Volumes; 
2. Выбрать: МАТ=1    TYPE=SOLID45; 
3. Нажать ОК ; 
4. PrPr  Meshing  Size Cntrls  Manual Size  Lines  All Lines; 
5. Задать: NDIV=12; 
6. Нажать ОК; 
7. PrPr  Meshing  Mesh   -Volumes- Mapped  4 to 6 Sided  Pick All.  

13. Вывести на экран изображение только контактных поверхностей А3 и А18: 
1. UM  Plot Ctrls   Pan, Zoom, Rotate; 
2. Нажать кнопку Top; 
3. UM  Plot  Lines; 
4. UM Select  Entities; 
5. Выбрать Areas в верхнем окне меню Select Entities; 
6. Выбрать во втором окне By Num/Pick; 
7. Поставит метку в окне From Full; 
8. Нажать Apply; 
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9. Поставить метку в окне Polygon меню Select areas; 
10. Выбрать контактирующие поверхности объемов; 
11. Нажать ОК; 
12. Выбрать Nodes в верхнем окне меню Select Entities; 
13. Выбрать во втором сверху окне Attached to; 
14. Поставить метку в окне Areas, All; 
15. Нажать ОК; 
16. UM  Plot Areas;  
17. Нажать Iso в меню Pan-Zoom-Rotate; 
18. UM  List  Areas; 
19. Убедиться, что присутствует изображение только двух поверхностей А3 и А18; 
20. Закрыть окно ALIST; 
21. UM  Plot  Nodes. 

 

Рис. 10.5. Конечно-элементная модель 

14. Связать перемещения совпадающих узлов, которые происходят в направлении 
нормали к контактирующим поверхностям (см. рис. 10.6): 

1. Сделать активной систему координат, совпадающей с Working Plane; 
2. UM  Work Plane   Change Active CS to  Working Plane; 
3. PrPr  Coupling/Ceqn   Coincident Nodes; 
4. Выбрать в окне DOF  for coupled nodes  перемещение UZ; 
5. Нажать ОК. 

15. Вывести на экран полное изображение конечно-элементной модели: 
1. UM  Select  Everything;  
2. MM  Plot  Elements. 
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Рис. 10.6. Условное отображение связанных узлов 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 



66 

 

11. МОДЕЛИРОВАНИЕ НАГРУЗКИ 

11.1. Нагружение сосредоточенными силами и моментами (см. рис. 11.1) 
1. PrPr  Loads   Define Loads   Apply  Structural  Force/Moment  On 

Keypoints (On Nodes). 
2. Выбрать ключевую точку КР5. 
3. Нажать ОК. 
4. Выбрать в окне Lab компоненту вектора нагрузки FY.  
5. Задать величину силы VALUE=1000(H). 
6. Нажать Apply. 
7. Выбрать ключевую точку КР8 (узел). 
8. Нажать ОК. 
9. Выбрать в окне Lab компоненту вектора силы FX. 
10. Задать:  VALUE=2000(H). 

 

 
Рис. 11.1. Условное отображение векторов нагрузок 

11.2. Нагружение силой веса 
1. PrPr    Loads   Define Loads   Apply  Structural  Inertia  Gravity  

Global. 
2. Задать величину ускорения свободного падения (нагружение выполняется по той 

оси, по которой действует сила веса) ASEL Y= -9.8(м/с2). 
3. Нажать ОК. 

11.3. Нагружение давлением, нормальным к поверхности (см. рис. 11.2) 
1. PrPr  Loads   Define Loads   Apply  Structural  Pressure  On Areas. 
2. Выбрать поверхность А23. 
3. Нажать ОК. 
4. Задать величину давления (положительное давление действует в тело) 
5. VALUE=100(Па). 
6. Выбрать в качестве типа визуализации давления – стрелки: 

1. UM  Plot Ctrls  Symbols; 
2. Выбрать Pressures в окне Surface load Symbols; 
3. Выбрать Arrows в окне Show pres and convect as;  
4. Нажать ОК. 



67 

 

 

Рис.11.2. Условное отображение давления 

11.4. Нагружение модели давлением, действующим под углом к поверхности. 
Моделирование такой нагрузки осуществляется с помощью элементов поверхностных 
эффектов (см. рис. 11.3). 

1. Выделить из модели поверхность, к которой необходимо приложить нагрузку: 
1. UM  Select Entities; 
2. Выбрать  Areas и By Num/Pick в окнах меню Select Entities; 
3. Поставить метку в окне From Full; 
4. Нажать Apply; 
5. Выбрать поверхность А12; 
6. Нажать ОК; 
7. Выбрать Nodes и Attached to в окнах меню Select Entities; 
8. Поставить метку в окне Areas, All; 
9. Нажать ОК. 

2. Вывести на экран изображение выделенных узлов: 
1. UM  Plot  Nodes. 

3. Выбрать элемент поверхностного эффекта: 
1. PrPr  Element type   Add/Edit/Delete  Add; 
2. Выбрать в левом окне Surface Effect; 
3. Выбрать в правом окне элемент Structural 154; 
4. Нажать ОК; 
5. Нажать Options; 
6. Выбрать следующие значения ключей: К4=Exclude; K6=Pos and neg pres; K11=Prj 

Area w/Tan;  K12=pres applied; 
7. Нажать ОК; 
8. Нажать Close.  
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Рис. 11.3. Добавление  элемента с поверхностным эффектом  

4. Задать Real constants для элементов Surf 154: 
1. PrPr  Real Constants   Add 
2. Выбрать элемент SURF 154 
3. Нажать ОК 
4. Задать TKI=0.0005м 
5. Нажать ОК 
6. Нажать Close 

5. Создать элементы поверхностного эффекта: 
1. PrPr  Modeling   Create  Elements   Elem Attributes; 
2. Выбрать: TYPE=SURF154; MAT=1; REAL=1; 
3. Нажать ОК; 
4. PrPr   Create  Elements  Surf/Contact   Surf Effect  Generl Surface  
No extra Node  Pick All. 

6. Нагрузить элементы поверхностного эффекта давлением , действующим по 
направлениям осей Х, Y и Z (см. рис. 11.4): 

1. UM  Select  Entities; 
2. Выбрать в верхних двух окнах соответственно Elements и By Attributes; 
3. Поставить метку в окне Elem type num; 
4. Задать тип элемента 2 в окне Min, Max, Inc; 
5. Поставить метку в окне From Full; 
6. Нажать ОК; 
7. UM  Plot Elements; 
8. PrPr  Loads   Define Loads   Apply  Structural  Pressure  On 

Elements; 
9. Выбрать элементы с номерами 3469…3480 (один столбец на рис. 11.4); 
10. Нажать ОК; 
11. Задать параметр LKEY=5; 
12. Задать модуль нагрузки VALUE=1000(Па); 
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13. Задать следующие направляющие косинусы: с осью х – VAL2=1; с осью у – 
Val2=0; с осью z – VAL3=0; 

14. Нажать Apply; 
15. Выбрать элементы с номерами 3481…3492 (второй столбец на рис. 11.4); 
16. Нажать ОК; 
17. Задать следующие направляющие косинусы: с осью х – VAL2=0; с осью у – 

Val3=1; с осью z – VAL4=0; 
18. Нажать Apply; 
19. Выбрать элементы с номерами 3493…3504 (третий столбец на рис. 11.4); 
20. Нажать ОК; 
21. Задать следующие направляющие косинусы: с осью х – VAL2=0; с осью у – 

Val2=0; с осью z – VAL3=1; 
22. Нажать ОК.  

 

 

Рис. 11.4. Условное отображение нагрузки, приложенной под определенным углом 

11.5. Нагружение модели полем центробежных сил 
1. PrPr  Loads   Define Loads   Apply  Structural  Inertia  Angular 

Velocity  Global. 
2. Задать компоненты вектора угловой скорости: OMEGX=0; OMEGY=1000 (рад/с); 

OMEGZ=0. 
3. Нажать ОК. Сделать скриншоты. 
4. Сохранить модель. Уничтожить все данные операцией Clear & Start New . 

11.6. Приложение температурной нагрузки, расчёт и анализ результатов. 
Рассматривается плоская задача о распределении температур в плоскости разъёма 
формы. Сечение имеет вид прямоугольника. Показывается, как учесть зависимость 
свойств материала (модуля упругости и коэффициента линейного расширения) от 
температуры. А также, как задать разные температуры для узлов модели. 

1. Построить прямоугольник: 
1. PrPr   Create  Rectangle   By Dimension; 
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2. Задать х1=0; х2=4; у1=0; у2=2; 
3. Нажать ОК. 

2. Выбрать тип элемента: 
1. PrPr  Element type   Add/Edit/Delete  Add; 
2. Выбрать в левом окне Shell; 
3. Выбрать в правом окне Elastic 4 node 63; 
4. Нажать ОК; 
5. Нажать Сlose. 

3. Задать Real Constants: 
1. PrPr  Real Constants   Add  OK; 
2. Задать: ТК(I)=0.04(м); 
3. Задать ОК. 
4. Нажать Сlose. 

4. Задать свойства материала: 
1. В окне Material Models Available выбрать Structural – Density и задать плотность 

DENS = 7800 (кг/м3).  
2. Затем выбрать Structural – Linear – Elastic – Isotropic. Нажимайте кнопу Add 

Temperature, пока в окне не будет пять столбцов для ввода данных; 
3. Задать в поле Temperatures: T1=OC; T2=200C; T3=400C; T4=600C; T5=800C; 
4. Задать для каждой температуры одинаковый коэффициент Пуассона PRXY=0.3; 
5. Задайте для каждой температуры разные модули упругости ЕХ: EX1=1, 

96·1011Па; EX2=1,7·1011Па; EX3=1,55·1011Па; EX4=1,4·1011Па; EX5=1,0·1011Па; 
6. Нажать OK; 
7. Выбрать Structural – Thermal Expansion – Secant Coefficient – Isotropic 

(коэффициент линейного расширения); 
8. Нажимайте кнопу Add Temperature, пока в окне не будет пять столбцов для ввода 

данных; 
9. Задать в поле Temperatures: T1=OC; T2=200C; T3=400C; T4=600C; T5=800C; 
10. Задать для каждой температуры разные коэффициенты линейного расширения 

ALPX: C1=0,11·10-4 1/К; C2=0,113·10-4 1/К; C3=0,12·10-4 1/К; C4=0,125·10-4 1/К; 
C5=0,13·10-4 1/К; 

11. Нажать ОК. 
5.  Построить упорядоченную сетку конечных элементов: 

1. PrPr  Meshing  Size Cntrls   Manual Size  Picked Lines; 
2. Выбрать ребра L1 и L3; 
3. Нажать ОК; 
4. Задать: NDIV=4; 
5. Нажать Apply; 
6. Выбрать ребра L2 и L4; 
7. Нажать ОК; 
8. Задать: NDIV=3; 
9. Нажать ОК; 
10. PrPr  Meshing  Mesh   Areas  Mapped  3 or 4 sided. 

6. Вывести на экран изображение узлов и их  номеров UM → PlotCtrls → Numbering. 
7. Задать температурную нагрузку: 



71 

 

1. PrPr  Loads   Define Loads   Apply  Structural  Temperature  On 
Nodes; 

2. Выбрать узлы с номерами 15…20 (внутренние узлы); 
3. Нажать ОК; 
4. Задать: VAL1=800; 
5. Нажать Apply; 
6. Выбрать все периферийные узлы; 
7. Нажать ОК; 
8. Задать VAL1=400; 
9. Нажать ОК. 
10. Отобразить список узлов и приложенные в них температуры 

UMListLoadsBodyOn All Nodes. Сохранить. 
11. Отобразить распределение температур в графическом виде (см. рис. 11.5). UM → 

PlotCtrls → Symbols → Body Load Symbols → Structural temps. Сохранить. 

 

Рис. 11.5. Распределение температур вдоль пластины 

12. Жёстко закрепить узел 17. PrPr  Loads   Define Loads   Apply  
Structural  Displacement  On Nodes. Выбрать узел 17, затем All DOF. 

13. Нажать ОК.  
14. Выполнить статический расчёт. Установка типа расчета: MM → Solution → 

Analysis Type → New Analysis → Static. Запустите модель на расчет: Solution → 
Solve → Current LS → OK. Должна появиться табличка Solution is done!  

15. Зайдите MM → General Postproc → Plot Results  → Contour Plot → Nodal Solu. 
Отобразите эквивалентные напряжения в конструкции: Stress → von Mises 
stress; 

16. Отобразите суммарные перемещения в модели: MM → General Postproc → Plot 
Results  → Cntour Plot → Nodal Solu DOF Solution → Displacement Vector 
Sum. 

17. Сохраните скриншоты. 
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ЗАКЛЮЧЕНИЕ 

Рассмотренные в данном учебном пособии примеры являются базовым уровнем  для 

студентов, использующих Ansys Mechanical для прочностных расчетов. На примере расчета 

простых конструкций показаны возможности программного пакета по построению конечно-

элементных моделей, приложению нагрузок и расчету. Рассмотрены: 

 интерфейс Ansys Mechanical; 

 задание типа конечных элементов (45, 63, 154, 181, 185, 186, 188); 

 задание Real Constants для этих типов конечных элементов; 

  задание свойств материалов, в т.ч. в зависимости от температуры; 

 задание поперечных сечений и функций толщины; 

 создание ключевых точек, линий, поверхностей, объёмных тел, узлов, элементов; 

 операции перемещения, копирования, разделения, склеивания, объединения; 

 создание сеток конечных элементов, оценка их качества, модификация сеток; 

 приложение закреплений, сил, моментов, давлений, угловой скорости, гравитации, 

температур, поверхностных эффектов; 

 использование координатных систем и рабочей плоскости; 

 использование меню Select для поиска нужных объектов в модели по различным 

критериям; 

 импорт CAD-геометрии из сторонних пакетов и её доработка в Ansys Mechanical; 

 связывание перемещений узлов на разных телах по координатам или уравнениями; 

 проведение статических и частотных (модальных) расчётов; 

 анализ результатов: вывод деформаций, напряжений, частот и форм; 

Примеры построены таким образом, что позволяют изучить большое количество 

функций Ansys Mechanical, которые понадобятся при выполнении курсовых и проектных работ 

на старших курсах.  
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